These forums are read-only!
Drupal Site Installation - Having problems..
  • Hey everyone!

    This question is not so much about Slicehost, but Drupal and MySQL and some problems I'm running into. At this point I'm stumped so I figured I would ask here to see if anyone could help me out :)

    So I'm running into some problems installing a new Drupal site as a subdirectory of a site that is already up and running. I'll do my best to explain.

    Steps taken so far:

    1. Created a new MySQL database, wxyz
    2. In MySQL ran the command: GRANT ALL ON wzxy.* TO user@'localhost' IDENTIFIED BY 'password';
    3. Ran the command: FLUSH PRIVILEGES;
    4. In my /sites folder created a subfolder called: example.com.new-site
    5. In that folder I created a new files folder and added a fresh settings.php file
    6. In settings.php I pointed to my new database: $db_url = 'mysqli://user:password@localhost/wxyz';
    7. I also added this: $base_url = 'http://www.example.com/new-site';
    8. I added the following to my .htaccess file:
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} ^/new-site/.*
    RewriteRule ^(.*)$ /new-site/index.php?q=$1 [L,QSA]
    9. In Terminal I added a sym link to point to the new directry: ln -s . new-site

    Result? Nada. I get an error message saying user doesn't have access to that database. I've checked and double checked everything. I have four other Drupal sites running on this installation, all using the same credentials. As a test, I pointed my settings.php file to an existing database and it worked fine. As soon as I point it to a new database it fails. I ran the command, SHOW GRANTS FOR user@localhost; and it clearly says I have all privileges on the new database.

    Is there something stupid I'm missing? Any feedback is greatly appreciated.

    Thanks!
    Andrew
  • sorry mate, this is black magic for me, i ask my brother. stay tuned!

    _____________________________________________________________
    Oferty firm
  • That should totally work I reckon.

    My guess would be a typo in the username or 'localhost' spelt wrong ? or the password ? or the db name ?

    what if you make the username, password and dbname all 'a' and give that a go :)

    also first, maybe check the mysql log for more info: tali /var/log/mysql.err (or something like that) just after trying to log in .. it might useful info in there.