These forums are read-only!
Vsftp Chroot - Can't write files [SOLVED]
  • Hi

    I've setup vsftpd, and enabled local user access and chrooting to the user's home directory. I can login as a user and have read access to files, but I cannot write through ftp. I get a 550 Permission Denied error.
    The home directories have these permissions:
    drwxr-xr-x 8 stephen stephen 4096 2008-04-01 07:55 stephen
    My /etc/vsftpd.conf file: http://paste.stgraber.org/2269.
    I'd really prefer to have them not world readable, and only read/write for www-data and the user, but not sure how to do this.

    I think the problem is that the user that vsftpd runs as does not have write access to the home directories. What's the best solution to this? (Yes, I know it's SFTP, but this is for my archaic dad to use and his ftp client doesn't support SFTP... :
  • I believe when you login as a user via FTP to a vsftpd server, you have all the authority of that particular Unix user. So in your case, if you're logging into FTP as stephen, you should have permission to write to stephen's home directory.

    However, I noticed that in your vsftpd config file, you've got write_enable commented out. You'll have to uncomment that and set it to YES to enable writes. Also, you might check /var/log/syslog and /var/log/daemon.log for more useful errors.
  • Can't believe I missed that option!

    Have uncommented that option and it's all working fine now.. Thanks a lot.

    Jordan